Introduction

This guide is intended to download and start a Lyberix wallet, on a Windows 32 or 64 bit, Ubuntu 16.04 64bit or an Ubuntu 18.04 64bit.

First the basic requirements:

  1. A main computer (Your everyday computer) – This will run the wallet and hold your Lyberix. If you have a masternode or plan to enable one, you will need a local wallet in addition to your server. Please refer to our Masternode Setup Guide for more info.

Configuration

1) Download the wallet from our Github site https://github.com/lyberix/lyberix/releases. Make sure you download the appropriate version for your computer operating system.

2) Uncompress the wallet. Depending on the downloaded file name, you should use the appropriate command:

For Linux:

tar zxvf [walletfilename]

For Windows:

Using the Windows explorer, right click on the downloaded file and click on extract to… Follow the instructions to uncompress it in a folder of your choice.

3) Install the dependencies.

First, you must install BerkelyDB 4.8 libs and some dependencies on your Linux computer.

For Ubuntu Linux 16.04:
sudo add-apt-repository ppa:bitcoin/bitcoin [Accept the conditions by pressing enter]
sudo apt-get update
sudo apt-get install libdb4.8-dev libdb4.8++-dev
sudo apt install libboost-system1.58.0 libboost-filesystem1.58.0 libboost-program-options1.58.0 libboost-thread1.58.0 libqrencode3  libdb4.8-dev libdb4.8++-dev

For Ubuntu Linux 18.04:

wget http://download.oracle.com/berkeley-db/db-4.8.30.zip
unzip db-4.8.30.zip
cd db-4.8.30
cd build_unix/
../dist/configure --prefix=/usr/local --enable-cxx
make
sudo make install
sudo apt install libboost-system1.65.0 libboost-filesystem1.65.0 libboost-program-options1.65.0 libboost-thread1.65.0

For Windows no dependencies are needed.

4) Open the wallet.

./lyberixv3-qt

Now, enjoy and start staking!

Leave a Reply

Your email address will not be published. Required fields are marked *